• 1 رای - 5 میانگین
  • 1
  • 2
  • 3
  • 4
  • 5
yii2 intl persian date extention
#1
عنوان/شرح: extention تاریخ فارسی/شمسی برای yii framework 2
نویسنده/برنامه نویس: احسان رضایی
مجوز: پروانهٔ عمومی همگانی گنو نسخه 3 / GNU General Public License (GPL Version 3)
تماس:
mr[dot]rezaee121[at]gmail.com
لینک پروژه: https://github.com/rezaei121/yii2-pdate
گزارش مشکلات:
https://github.com/rezaei121/yii2-pdate/issues
انشعاب/Clone:
کد:
https://github.com/rezaei121/yii2-pdate.git

نصب:
The preferred way to install this extension is through composer
Either run
کد:
php composer.phar require --prefer-dist developit/yii2-pdate "~1.0"
or add
کد:
"developit/yii2-pdate": "~1.0"
to the require section of your composer.json file

استفاده:
In view
کد پی‌اچ‌پی:
use developit\pdate\Date;
echo 
Date::widget(); // 00:30 - 1395/07/14
// echo Date::widget(['value' => 1475594367]); // 18:49 - 1395/07/13
// echo Date::widget(['value' => time(), 'format' => 'yyyy/MM/dd']); // 1395/07/14 
هر چیزی که در جستن آنی آنی...
غایب
  پاسخ
تشکر شده توسط : Null Y.P.Y
#2
blocker issue
می خوام لخت لخت نصبش کنم Big Grin
کد:
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - yiisoft/yii2 2.0.9 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable |
.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.8 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable ->
no matching package found.
    - yiisoft/yii2 2.0.7 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable ->
no matching package found.
    - yiisoft/yii2 2.0.6 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stable -> no matching pa
kage found.
    - yiisoft/yii2 2.0.5 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stable -> no matching pa
kage found.
    - yiisoft/yii2 2.0.4 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stable -> no matching pa
kage found.
    - yiisoft/yii2 2.0.3 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stable -> no matching pa
kage found.
    - yiisoft/yii2 2.0.2 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stable -> no matching pa
kage found.
    - yiisoft/yii2 2.0.11.2 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable
| 1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.11.1 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable
| 1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.11 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable |
1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.10 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable |
1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.1 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stable -> no matching pa
kage found.
    - yiisoft/yii2 2.0.0 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stable -> no matching pa
kage found.
    - developit/yii2-pdate 1.0 requires yiisoft/yii2 ~2.0 -> satisfiable by yiisoft/yii2[2.0.0, 2.0
1, 2.0.10, 2.0.11, 2.0.11.1, 2.0.11.2, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6, 2.0.7, 2.0.8, 2.0.9].
    - Installation request for developit/yii2-pdate ~1.0 -> satisfiable by developit/yii2-pdate[1.0
.

Potential causes:
- A typo in the package name
- The package is not available in a stable-enough version according to your minimum-stability sett
ng
   see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.

Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.

Installation failed, reverting ./composer.json to its original content.

جدای از این اگر composer رو در PATH سیستمت اضافه کنی نیازی به نوشتن php composer.phar نیست...
وبلاگ: Yousha.Blog.ir


 کد کمتر => خطای کمتر => قابل فهمتر => خوانایی بالاتر => نگهداری بهتر

  پاسخ
تشکر شده توسط : undefined
#3
فکر میکنم پوشه bower-asset و محتویات داخلش رو اصلا نداری که اینطور ترکیده.

نقل قول:جدای از این اگر composer رو در PATH سیستمت اضافه کنی نیازی به نوشتن php composer.phar نیست...
اون composer.phar برای زمانی بود که من ویندوزی بودم و از ابزار composer خود phpstorm استفاده میکردم(برای مقدار دهی، بروزرسانی و...).
هر چیزی که در جستن آنی آنی...
غایب
  پاسخ
تشکر شده توسط : Y.P.Y
#4
نقل قول:فکر میکنم پوشه bower-asset و محتویات داخلش رو اصلا نداری که اینطور ترکیده.
آره، هیچی ندارم فقط اومدم مستقیم و بی واسطه بگیرمش که خطا گرفت.

نقل قول:اون composer.phar برای زمانی بود که من ویندوزی بودم و از ابزار composer خود phpstorm استفاده میکردم
توی ویندوز هم همینطوره
اگر در PATH user یا PATH system اضافش کنی(با نصب Setup انجام میشه) میشه از composer از هرجا مستقیماً استفاده کرد.
وبلاگ: Yousha.Blog.ir


 کد کمتر => خطای کمتر => قابل فهمتر => خوانایی بالاتر => نگهداری بهتر

  پاسخ
تشکر شده توسط : undefined
#5
همونطور که پیداست و متوجه هستی من اصلا برای اکستنشن خودم bower تعریف نکردم، اون dependence هاشه که bower داره.

نقل قول:توی ویندوز هم همینطوره
اگر در PATH user یا PATH system اضافش کنی(با نصب Setup انجام میشه) میشه از composer از هرجا مستقیماً استفاده کرد.
یه چیزایی یادمه، انگار باید توی قسمتی با عنوان environment variable اضافه اش میکردیم یا یه همچین چیزی.
توی phpstorm زمانی که میخوایی composer init کنی مسیرُ از میپرسه و اگر بهش ندی خودش داخل پروژه برات اضافه اش میکنه.
هر چیزی که در جستن آنی آنی...
غایب
  پاسخ
تشکر شده توسط :
#6
(۱۳۹۵ اسفند ۱۳, ۰۴:۵۰ ق.ظ)Y.P.Y نوشته: blocker issue
می خوام لخت لخت نصبش کنم Big Grin
کد:
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - yiisoft/yii2 2.0.9 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable |
.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.8 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable ->
no matching package found.
    - yiisoft/yii2 2.0.7 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable ->
no matching package found.
    - yiisoft/yii2 2.0.6 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stable -> no matching pa
kage found.
    - yiisoft/yii2 2.0.5 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stable -> no matching pa
kage found.
    - yiisoft/yii2 2.0.4 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stable -> no matching pa
kage found.
    - yiisoft/yii2 2.0.3 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stable -> no matching pa
kage found.
    - yiisoft/yii2 2.0.2 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stable -> no matching pa
kage found.
    - yiisoft/yii2 2.0.11.2 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable
| 1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.11.1 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable
| 1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.11 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable |
1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.10 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable |
1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.1 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stable -> no matching pa
kage found.
    - yiisoft/yii2 2.0.0 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stable -> no matching pa
kage found.
    - developit/yii2-pdate 1.0 requires yiisoft/yii2 ~2.0 -> satisfiable by yiisoft/yii2[2.0.0, 2.0
1, 2.0.10, 2.0.11, 2.0.11.1, 2.0.11.2, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6, 2.0.7, 2.0.8, 2.0.9].
    - Installation request for developit/yii2-pdate ~1.0 -> satisfiable by developit/yii2-pdate[1.0
.

Potential causes:
- A typo in the package name
- The package is not available in a stable-enough version according to your minimum-stability sett
ng
   see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.

Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.

Installation failed, reverting ./composer.json to its original content.

جدای از این اگر composer رو در PATH سیستمت اضافه کنی نیازی به نوشتن php composer.phar نیست...

احسان فکر کنم من درست می گفتم، مشکل از نام پکیج req هستش، و نه نداشتن yii:
no matching package found
حتی اجازه نصب req رو هم نمیده.
وبلاگ: Yousha.Blog.ir


 کد کمتر => خطای کمتر => قابل فهمتر => خوانایی بالاتر => نگهداری بهتر

  پاسخ
تشکر شده توسط :
#7
نقل قول:احسان فکر کنم من درست می گفتم، مشکل از نام پکیج req هستش، و نه نداشتن yii:
no matching package found
حتی اجازه نصب req رو هم نمیده.

ببین منم مجبور کردی برم لخت لخت نصبش کنم Big Grin
مشکل اینجاست که نیازمندی ها رعایت نشده، اگر داخل yii کامپوزر update میشد خب این اتفاق نمیوفتاد.
برای حلش اول composer-asset-plugin رو نصب کن.
کد:
php composer global require "fxp/composer-asset-plugin:1.0.0"


فایل‌های پیوست تصاویر بندانگشتی
   
هر چیزی که در جستن آنی آنی...
غایب
  پاسخ
تشکر شده توسط : Y.P.Y


پرش به انجمن:


کاربران در حال بازدید این موضوع: 1 مهمان