• 0 رای - 0 میانگین
  • 1
  • 2
  • 3
  • 4
  • 5
opcache
#1
سلام دوستان مشکلم با opcache پابرجاست من از php 5.3.1 استفاده میکنم opcache را دانلود و از حالت زيپ خارج ودر آدرس xampp/php/ext کپی کردم. و تغییرات و کدهای مربوط به فایل php.ini را هم عینا برابر آموزش مربوط به ویندوز انجام دادم وقتی در محیط shall دستور php _v را اجرا میکنم پیام زیر مشاهده میشود:
کد پی‌اچ‌پی:
failed loading c:\ xampp\php\ext\php_opcache.del
PHP warning 
:PHP startup:Unable to load dynamic library'c:\xampp\php\ext\php_opcache.dll' the specified modulcould not be found
این هشدار چی ميگه :huh:
داخل اون فلدر بعد از خارج کردن از زيپ . opcache تعداد ۳فایل بود که یکی همین php_opcache.dll یکی red me و دو فایل دیگر هم بود که همه را به آدرس اکستنشن های php. کپی کردم
نکند برای نصب باید دستوراتی در محیط shall اجرا بشه لطفا راهنمایی کنید واجبه اجبارا پست تکراری ارسال کردم ممنونم راهنمایی میکنید......
شیفتگان پرواز را میل خزیدن نیست
  پاسخ
تشکر شده توسط :
#2
اکستنشن باید مخصوص نسخه PHP ای باشه که نصب داری: 5.6 7 7.1 7.2 ...
و معماریش هم باید با معماری php ت یکی باشه: x64 x86....
به thread safe و Non thread safe بودنش هم دقت کن

درضمن اون php_opcache.dll هست نه php_opcache.del
وبلاگ: Yousha.Blog.ir

صدام: "اگر با ارتش شاه ایران طرف بودیم، یک ماهه جنگ را می بردیم"
http://gulfnews.com/opinion/thinkers/ira...i-1.500997
  پاسخ
تشکر شده توسط : ayoubsys
#3
(۱۳۹۷ آبان ۲۲, ۱۱:۵۰ ب.ظ)Y.P.Y نوشته: اکستنشن باید مخصوص نسخه PHP ای باشه که نصب داری: 5.6 7 7.1 7.2 ...
و معماریش هم باید با معماری php ت یکی باشه: x64 x86....

درضمن اون php_opcache.dll هست نه php_opcache.del

سلام دوست عزیز ممنونم از پاسختون من از این لینک کدوم نسخه از php_opcache را باید دانلود کنم
نسخه php 5.3.1 و ویندوز7 نسخه 32بیتی
https://forum.iranphp.org/Thread-5-%D9%8...%DB%8C-PHP
شیفتگان پرواز را میل خزیدن نیست
  پاسخ
تشکر شده توسط :
#4
در php 5.6 این اکستنشن بصورت پیشفرض وجود داره و فقط کافیه که فعال بشه
php شما 5.3 هست. نمیدونم اصلاً میشه opcache ش رو پیدا کرد یا نه. قدیمه!

برنامه Command Prompt ویندوز رو باز کنید و باهاش برید داخل پوشه php. بعد دستور php -v رو بزنید. خروجیش چیه؟
وبلاگ: Yousha.Blog.ir

صدام: "اگر با ارتش شاه ایران طرف بودیم، یک ماهه جنگ را می بردیم"
http://gulfnews.com/opinion/thinkers/ira...i-1.500997
  پاسخ
تشکر شده توسط :
#5
(۱۳۹۷ آبان ۲۳, ۱۱:۵۴ ق.ظ)Y.P.Y نوشته: در php 5.6 این اکستنشن بصورت پیشفرض وجود داره و فقط کافیه که فعال بشه
php شما 5.3 هست. نمیدونم اصلاً میشه opcache ش رو پیدا کرد یا نه. قدیمه!

برنامه Command Prompt ویندوز رو باز کنید و باهاش برید داخل پوشه php. بعد دستور php -v رو بزنید. خروجیش چیه؟

سلام دوست عزیز ممنونم از وقتیکه اختصاص میدهید داخل تگ کد همون بالا نوشتم با چیزی که در محیط shell میده. تفاوتی نداره بالا داخل تگ کد پیغامو نوشتم. داخل فایل read me هم نوشته برای php5.3 میشه.......
شیفتگان پرواز را میل خزیدن نیست
  پاسخ
تشکر شده توسط :


پرش به انجمن:


کاربران در حال بازدید این موضوع: 1 مهمان