• 0 رای - 0 میانگین
  • 1
  • 2
  • 3
  • 4
  • 5
مشکل من با captcha و session
#1
دوستان من از دو سه تا کلاس کپچا استفاده کردم که آخریش simple captcha بود که با سشن خروجیش رو می فرسته ولی عکس العمل های مختلفی رو می گیرم . وقتی از ie جدید و firefox قدیمی تر استفاده می کنم کار می کنه و وقتی مقدار سشن رو چاپ می کنم نشون می ده . ولی با ff جدید و opera مقدار null بر می گردونه . همون کد . قضیه چیه این وسط . چی رو باید بررسی کنم . کد کاملا درسته؟؟؟؟؟؟
کم کم داره به جایی می رسه که بنویسم بهترین مرورگر واسه اجرا IE Big GrinBig Grin
چرا باید ff جدید با ff قدیمی یه کد رو به دو شکل اجرا کنند ؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟ مثلا ff 10 و ff13
  پاسخ
تشکر شده توسط :
#2
من یه نکته کلی را میگم شاید مشکلت را حل کنه و شایدم نه !
اگر هاست شما ویندوز باشه و تصویری که توی پی اچ پی میسازی پسوندش .jpg باشه عکس ساخته نمیشه و باید از پسوند های .png یا .gif استفاده بشه . من به شخصه خیلی از این captcha را دیدم که سر این قضیه کار نمیدادن ولی شما میگید توی ie باز میشه ! اگر مورد اول صحیح بود احتمالا مشکل توی تعریف کردن هدر هاست و چون ie اتوماتیک هدر ها تشخیص میده این قابلیت را داره ( از بین این همه مصیبت که برای کدر ها درست میکنه !!!) که هدر را بر اساس نوعش شناسایی کنه ( البته این یه نوع باگ هم هست !).
امیدوارم گفته های من مفید باشه .
  پاسخ
تشکر شده توسط : undefined alri
#3
البته هم کد و هم تصویرش ساخته می شه و لی وقتی توی session می ریزم می برم جای دیگه چاپ می کنم با موزیلا جدید کار نمی کنه با قدیمی کار می کنه .تو جدیده NULL بر می گردونه
  پاسخ
تشکر شده توسط :
#4
دوستان خبری نشد ؟؟
من این قضیه رو با ff10 تو لینوکس cent os تست کردم و کاملا کپچا رو نشون می ده . 10 آخرین آپدیت ریپو من بود . ولی با آخرین آپدیت ویندوز که 14 نشون نمی ده . نمی دونم چی کارش کنم .
re captcha هم که این قدر حروفش چرت و پرته که نمی شه خوندش .
  پاسخ
تشکر شده توسط :
#5
یه جا نمونه آپلود کن. بذار ما هم تستش کنیم.
غایب
  پاسخ
تشکر شده توسط :


پرش به انجمن:


کاربران در حال بازدید این موضوع: 1 مهمان