• 0 رای - 0 میانگین
  • 1
  • 2
  • 3
  • 4
  • 5
مشکل در نصب و استفاده kartik datagrid (حل شد)
#1
سلام
میشه یک نفر ساده و راحت طریقه نصب(دستی) و استفاده از kartik رو بگه؟
این کامپوزر بدجور کلافم کردهConfused کلی ادا در میاره و خطا میده
ممنون میشم یکی راهنمایی کنه
(یا به صورت کلی اصول نصب ماژول و... بگید که عالی میشه)
تشکر
  پاسخ
تشکر شده توسط :
#2
من تا حالا دستی نصب نکردم و میدونم این کار توصیه نمیشه.
از phpstorm و ابزار کامپوزرش استفاده کن کارتُ راحت تر میکنه.
هر چیزی که در جستن آنی آنی...
غایب
  پاسخ
تشکر شده توسط : ayoubsys
#3
سلام،
خب شما بگین چی کار میکنین؟ چه خطایی میگیرین؟
غایب
  پاسخ
تشکر شده توسط :
#4
(۱۳۹۵ خرداد ۱۷, ۰۲:۰۹ ق.ظ)undefined نوشته: من تا حالا دستی نصب نکردم و میدونم این کار توصیه نمیشه.
از phpstorm و ابزار کامپوزرش استفاده کن کارتُ راحت تر میکنه.

میشه اینو کمی بیشتر توضیح بدید، چون از همین ide استفاده میکنم

(۱۳۹۵ خرداد ۱۷, ۱۰:۱۴ ق.ظ)Alaa نوشته: سلام،
خب شما بگین چی کار میکنین؟ چه خطایی میگیرین؟

این 2 نمونش
   
   
  پاسخ
تشکر شده توسط :
#5
خب این خطاها رو سرچ کن.
مثلا برای اولی که میگه کامپوزر رو آپدیت کن خودش میگه از --no-plugins استفاده کن.
یعنی بنویس:
کد:
composer update --no-plugins
ببین جواب میده؟
غایب
  پاسخ
تشکر شده توسط :
#6
(۱۳۹۵ خرداد ۱۷, ۰۲:۰۹ ق.ظ)undefined نوشته: من تا حالا دستی نصب نکردم و میدونم این کار توصیه نمیشه.
از phpstorm و ابزار کامپوزرش استفاده کن کارتُ راحت تر میکنه.

این خطا رو میده
کد:
php.exe "C:\Program Files\ComposerSetup\composer.phar" require kartik-v/yii2-grid:3.1.x-dev -n --no-progress
The "yiisoft/yii2-composer" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option.
./composer.json has been updated
The "yiisoft/yii2-composer" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option.
Loading composer repositories with package information
Updating dependencies (including require-dev)
Failed to clone the git@github.com:jquery/jquery-dist.git repository, try running in interactive mode so that you can enter your GitHub credentials

Installation failed, reverting ./composer.json to its original content.

                                                                              
  [RuntimeException]                                                          
  Failed to execute git clone --mirror "git@github.com:jquery/jquery-dist.git  
  " "C:/Users/Milad/AppData/Local/Composer/vcs/git-github.com-jquery-jquery-d  
  ist.git/"                                                                    
                                                                              

require [--dev] [--prefer-source] [--prefer-dist] [--no-progress] [--no-update] [--no-scripts] [--update-no-dev] [--update-with-dependencies] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [--sort-packages] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--] [<packages>]...

(۱۳۹۵ خرداد ۱۷, ۱۲:۰۵ ب.ظ)Alaa نوشته: خب این خطاها رو سرچ کن.
مثلا برای اولی که میگه کامپوزر رو آپدیت کن خودش میگه از --no-plugins استفاده کن.
یعنی بنویس:
کد:
composer update --no-plugins
ببین جواب میده؟

اینا رو قبلا همه تست و سرچ کردم اما...
ببنید:
کد:
Milad@Milad-PC MINGW32 /e/xampp/htdocs/yii/advanced
$ composer update --no-plugins
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - yiisoft/yii2 2.0.8 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.7 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.6 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.6 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stable -> no matching package found.
    - Installation request for yiisoft/yii2 >=2.0.6 -> satisfiable by yiisoft/yii2[2.0.6, 2.0.7, 2.0.8].

Potential causes:
- A typo in the package name
- The package is not available in a stable-enough version according to your minimum-stability setting
   see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.

Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.

Milad@Milad-PC MINGW32 /e/xampp/htdocs/yii/advanced
$
  پاسخ
تشکر شده توسط :
#7
شما ظاهرا پکیج‌هات مشکل داره. همش با جی‌کوئری به مشکل برمیخوره.
یه نسخه جدید از Yii رو راه‌اندازی کن به نظر من. ببین باز هم همین خطاها رو میگیری؟
غایب
  پاسخ
تشکر شده توسط :
#8
(۱۳۹۵ خرداد ۱۷, ۱۲:۵۶ ب.ظ)Alaa نوشته: شما ظاهرا پکیج‌هات مشکل داره. همش با جی‌کوئری به مشکل برمیخوره.
یه نسخه جدید از Yii رو راه‌اندازی کن به نظر من. ببین باز هم همین خطاها رو میگیری؟
تشکر اینم حل شد! Idea
مشکل از توکن گیت هاب بود به با استفاده از این رفع شد.

kartik هم بدرستی نصب شد
خیلی خیلی از راهنمایی و کمک شما و سایرین ممنونم
  پاسخ
تشکر شده توسط :


پرش به انجمن:


کاربران در حال بازدید این موضوع: 1 مهمان