• 1 رای - 5 میانگین
  • 1
  • 2
  • 3
  • 4
  • 5
مشکل در اجرای کدهای Jquery در IE 6.7
#1
بسم الله..
سلام...
من در حال طراحی یک نرم افزار رزرواسیون بلیط های هواپیما و هتل و تور هستم برای یک شرکت خدمات مسافرتی و گردشگری...و البته این نرم افزار قراره به شرکت های دیگه هم فروخته بشه...
مشکل عمده ای که دارم اینه که بعضی امکانات این نرم افزار مثل منوها و اسلایدشویی که مشتری خواسته توی این سیستم بیاد با Jquery پیاده شده و مشکل بزرگ اینه که اون شرکت و شرکت های دیگه ای مثل اون همه با IE 6,7 کار میکنن و رسما دهن ما رو سرویس کردن .... از یک طرف میخوان اون امکانات باشه روی سایتشون و از طرف دیگه هرچی میگی آقا روی این browser نمیشه و بهتره ارتقا بدین browser هاتونو حالیشون نمیشه و میگن همینه که هست و باید درست کنی....
تو رو خدا اگه راهی سراغ دارین که بشه این مشکل رو برطرف کرد بهم بگین...هرچی سرچ کردم چیزی که کمکم کنه گیرم نیومد
بنده طعم ايمان را نمي چشد، تا اينكه دريابد آنچه اتفاق نيفتاده است نمي شد كه اتفاق بيفتد؛و آنچه شده و اتفاق افتاده است,نمي شد كه نشود و اتفاق نيفتد....حضرت علي(ع)
  پاسخ
تشکر شده توسط :
#2
ساده ترین راه حل برای حل مسله پاک کردن صورت مسله است.
با جی کیوری ننویس!!! Angel
  پاسخ
تشکر شده توسط : undefined
#3
یعنی مجبورن با این مرورگر کار کنن ؟ (دیوانه ان ؟ )
  پاسخ
تشکر شده توسط :
#4
نقل قول:ساده ترین راه حل برای حل مسله پاک کردن صورت مسله است.

اشتباه پاک کردی!
IE رو محدود کن و اجازه نده کسی باش سایتت رو ببینه AngelBig Grin
هر چیزی که در جستن آنی آنی...
غایب
  پاسخ
تشکر شده توسط : oia
#5
چاره ای ندارم....من برای یک شرکت نرم افزاری دارم می نویسم و اونم این پروژه رو داره میده به شرکت های مسافرتی....یکی از این شرکت ها هم که اینو خریده باز خودش با چند تا شرکت مسافرتی دیگه که میشن یوزرهای این نرم افزار قرارداد داره که از این نرم افزار استفاده کنن....
و بدبختی اینجاست که سیستم ها همگی قدیمی ، و همه هم اکثرا اینترنت اکسپلورر 6.7 و نهایتا 8 کار می کنن...حتی اگه برای شرکت اصلی هم خودم برم کروم یا فایرفاکس نصب کنم بقیه رو نمیشه کاری کرد....شرکت هم اصرار داره که باید فلان منو رو با جی کوئری در بیاری و فلان اسلایدشو رو هم همینطور...

میگم بابا این مثل این میمونه که موتور فراری رو بذاری رو اتاق پیکان...خب معلومه کار نمیکنه این ماشین!Dodgy

حتی گفتم آی ای رو محدود کنما اما عملا نمیشه...چون شرکت گفته این کارو نکن....
بنده طعم ايمان را نمي چشد، تا اينكه دريابد آنچه اتفاق نيفتاده است نمي شد كه اتفاق بيفتد؛و آنچه شده و اتفاق افتاده است,نمي شد كه نشود و اتفاق نيفتد....حضرت علي(ع)
  پاسخ
تشکر شده توسط :
#6
نقل قول:آقا روی این browser نمیشه و بهتره ارتقا بدین browser هاتونو

درستش هم همینه، اما برای اینکه به مشکل بر نخورید باید توی قرارداد یه بندی چیزی درج میکردین.

خب، من از جی کوئری توی IE 6 استفاده کردم. کلا جی کوئری اجرا نمیشه یا فقط بخش هایی از اون(مثل اسلاید هاش)؟
هر چیزی که در جستن آنی آنی...
غایب
  پاسخ
تشکر شده توسط :
#7
بعضی ماژول ها کلش اجرا نمیشه...بعضی ها هم بخش هاییش...
بنده طعم ايمان را نمي چشد، تا اينكه دريابد آنچه اتفاق نيفتاده است نمي شد كه اتفاق بيفتد؛و آنچه شده و اتفاق افتاده است,نمي شد كه نشود و اتفاق نيفتد....حضرت علي(ع)
  پاسخ
تشکر شده توسط :
#8
آقا بنظر من اگه نمیخوان browser رو آپدیت کنن قرارداد رو همین الان کنسل کن، باور کن ارزش نداره!

یا حداقل 2 میلیون بزار رو قرارداد تا بجای جی کوئری بری سراغ مشابه های جاوا اسکریپتش
هر که با مرغ هوا دوست شود - خوابش آرامترین خواب جهان خواهد بود.
  پاسخ
تشکر شده توسط : Hamid
#9
نقل قول:بعضی ماژول ها کلش اجرا نمیشه...بعضی ها هم بخش هاییش...

یه راه سادش اینه که مشابه جاوا اسکریپتش رو بنویسی که البته مقداری هم زمان بره .
هر چیزی که در جستن آنی آنی...
غایب
  پاسخ
تشکر شده توسط :
#10
نه بابا وقت این کارو ندارم.... نبود راه دیگه؟Huh
بنده طعم ايمان را نمي چشد، تا اينكه دريابد آنچه اتفاق نيفتاده است نمي شد كه اتفاق بيفتد؛و آنچه شده و اتفاق افتاده است,نمي شد كه نشود و اتفاق نيفتد....حضرت علي(ع)
  پاسخ
تشکر شده توسط :


پرش به انجمن:


کاربران در حال بازدید این موضوع: 1 مهمان