• 0 رای - 0 میانگین
  • 1
  • 2
  • 3
  • 4
  • 5
مشکل با ie
#1
سلام
فکر می کنید همچین خطایی علتش چی باشه ؟
[عکس: algxlbzdbzqyn9q9ybk3.jpg]
ممنون میشم راهنمایی کنید خیلی کارم گیره .
یه توضیح کوچیک بدم که کد های من تو تمام مرورگرها به جز IE کاملا درست کار می کنه

  پاسخ
تشکر شده توسط :
#2
خب دلیل این موضوع اینه که :
اینترنت اکسپلورر اعصاب خورد کن خنگ تا تکون میخوره میره رو آفلاین !
من بخاطر همین مشکل توی پروژه دانشگاه نوشتم "لطفا از IE استفاده نکنید !!! "
بعدا فهمیدم که چقدر مشکل کوچولو بود !
وقتی میخوای AJAX کار کنی روی لوکال این مشکل پیش میاد !
شما برای تست هر بار که خواستی یه کد AJAX اجرا کنی اول برو تیک Work Offline رو بردار تا مشکلت حل بشه !
چون هر دفعه که صفحه لود میشه میره رو آفلاین !
اگه بدونی من چقدر درگیر این موضوع شدم !!!! Confused
  پاسخ
تشکر شده توسط : paull
#3
کدتون رو ایجا بزارید تا بگم. ای به یک سی می کلن یا ویرگول حساسه این ماله اونه
  پاسخ
تشکر شده توسط : paull
#4
(آقا این IE پدر ما رو در آورد )
با تشکر از همه دوستان
مشکل همان بود که جناب zoghal عرض کردند ...
چون با حذف قسمتی کمی از کد کار کرد .
(واقعا بروبچه های IranPhp هر کدوم یه استادن)



  پاسخ
تشکر شده توسط :
#5
اول تشکر مخصوص خدمت آقا صالح
بعد اینکه باورتون نمیشه مشکل چی بود من خط به خط کد ها رو گشتم تا به این کد رسیدم :
کد پی‌اچ‌پی:
this.labeler=function(pid,class,message){ 
و اون رو تبدیل به :
کد پی‌اچ‌پی:
this.labeler=function(pid,cclass,message){ 
کردم و درست شد .
در واقع مشکل لغت class بود که من استفاده کرده بودم .
از همه دوستانی که راهنمایی کردند ممنونم .
Big GrinBig GrinBig Grin
  پاسخ
تشکر شده توسط : Padideh zoghal
#6
ای خوبه Big Grin یک ایراداتی میگیره که آدم شاخ در میاره
  پاسخ
تشکر شده توسط : paull


پرش به انجمن:


کاربران در حال بازدید این موضوع: 1 مهمان