• 0 رای - 0 میانگین
  • 1
  • 2
  • 3
  • 4
  • 5
كمك
#1
سلام
من تازه يادگيري php رو شروع كردم روي سيستمم wampserver رو نصب كردم
حالا مشكل من اينه كه هر فايل php رو كه كد نويسي ميكنم (البته كدهاي آماده كه در كتاب بصورت تمرين و نمونه ارائه شده ) سيستم اجرا نمي كنه و متن كد رو چاپ ميكنه
2- من ميخوام يه صفحه وب طراحي كنم البته با html مشكل زيادي ندارم يعني چيزائي ( اگه بشه اسمشو صفحه وب گذاشت) كه طراحي ميكنم اجرا ميشن و كار ميكنند اما وقتي كدهاي پي اچ پي رو بهش اضافه ميكنم يا ميخوام در يه قسمتهائي از فايل هاي پي اچ پي استفاده كنم دستورات پي اچ پي اجرا نميشن
البته اينو بگم كه فايلهي مربوط به پي اچ پي رو دقيقا" در مسير لوكال هاست اجرا ميكنم
با سپاس ار اهنمائيتون
  پاسخ
تشکر شده توسط :
#2
ممنون از راهنمائي هاي توپتون
فكر نمي كردم به اين زودي جواب بگيرم
  پاسخ
تشکر شده توسط :
#3
خوب ببین wamp server اصلا اجرا شده یا نه ؟

  پاسخ
تشکر شده توسط : oia
#4
نقل قول:حالا مشكل من اينه كه هر فايل php رو كه كد نويسي ميكنم (البته كدهاي آماده كه در كتاب بصورت تمرين و نمونه ارائه شده ) سيستم اجرا نمي كنه و متن كد رو چاپ ميكنه
باید کد هاتو درون تگ های PHP بزاری
کد پی‌اچ‌پی:
<?PHP

phpinfo
();
?>

لطفا از عنوان های بهتری برای بحث هایی که ایجاد می کنید استفاده کنید.
موفق باشید
  پاسخ
تشکر شده توسط :
#5
سلام !
شما یک نمونه از کدی که تایپ کردید رو قرار بدید ؟
و همینطور موضوع ران بودن شبیه ساز سرورتون رو هم چک کنید ؟


توی مرورگرتون بزنید : http://localhost ببینید میاد بالا و یا خیر ؟

امری بود در خدمتم
موفق باشید .Heart
  پاسخ
تشکر شده توسط :
#6
(۱۳۹۰ اردیبهشت ۲۲, ۰۳:۲۸ ب.ظ)niman2d نوشته: سلام !
شما یک نمونه از کدی که تایپ کردید رو قرار بدید ؟
و همینطور موضوع ران بودن شبیه ساز سرورتون رو هم چک کنید ؟


توی مرورگرتون بزنید : http://localhost ببینید میاد بالا و یا خیر ؟

امری بود در خدمتم
موفق باشید .Heart
ممنون از لطفتون
wampserver فعاله و بالا مياد
كدها هم درستن يعني اشخاص ديگه اي كه بردند و اجرا كردند درست كار ميكنند كدها برنامه هاي آموزشي ساده اي هستند كه از كتاب يا سي دي هاي آموزشي كپي شدند و اونا رو در مسير لوكال هاست قرار ميدم

  پاسخ
تشکر شده توسط :
#7
سلام !
ممنون میشم فایل کامل یکی از کدهاتون رو پیوست کنید....


با احترام
  پاسخ
تشکر شده توسط :
#8
ببین به نظر من یکی از این حالت ها باید باشه :

1- WAMP فعال نیست ! ( شاید اجرا میشه ولی فعال نیست ! وب سرور اجرا نشده )
2- کد ها توی تگ php نیست :
کد پی‌اچ‌پی:
<?php //code  ?>
3- فایلت رو با پسوندی غیر از php ذخیره کردی ( مثلا HTML یا .. )
4- آدرس لوکال رو توی مرورگرت درست نمیدی !
5- یادم رفت ولی به قول اساتید اگه کدت رو بذاری میتونیم بهتر کمکت کنیم که مشکل از کجاست !

  پاسخ
تشکر شده توسط : Padideh
#9
(۱۳۹۰ اردیبهشت ۲۴, ۱۲:۱۳ ب.ظ)Bojbaj نوشته: ببین به نظر من یکی از این حالت ها باید باشه :

1- WAMP فعال نیست ! ( شاید اجرا میشه ولی فعال نیست ! وب سرور اجرا نشده )
2- کد ها توی تگ php نیست :
کد پی‌اچ‌پی:
<?php //code  ?>
3- فایلت رو با پسوندی غیر از php ذخیره کردی ( مثلا HTML یا .. )
4- آدرس لوکال رو توی مرورگرت درست نمیدی !
5- یادم رفت ولی به قول اساتید اگه کدت رو بذاری میتونیم بهتر کمکت کنیم که مشکل از کجاست !
سلام
آقا ممنون از همه مشكل رفع شد
آدرس لوكال رو درست نزده بودم ( مبتدي هستم ديگهWink)
دست گل همتون درد نكنه
  پاسخ
تشکر شده توسط : Padideh
#10
لطفا برای تاپیک هاتون از عبارات مناسب استفاده کنید.
  پاسخ
تشکر شده توسط : paull parvane


پرش به انجمن:


کاربران در حال بازدید این موضوع: 1 مهمان