• 2 رای - 3.5 میانگین
  • 1
  • 2
  • 3
  • 4
  • 5
فعال سازی .htaccess در Localhost
#1
Thumbs Up 
سلام دوستان ، من خودم از Easyphp استفاده میکنم و در فایل httpd.conf خط زیر رو # رو از اولش برداشتم و فعالش کردم :

LoadModule rewrite_module modules/mod_rewrite.so

و سرور رو ریستارت کردم ، اما تغییری حاصل نشد ،

ممنون میشم دوستان راهنمایی کنن !
---------------------------------------------------------------------------
خدایا ، مگر می شود تو باشی و ما تنها باشیم ؟
  پاسخ
تشکر شده توسط :
#2
من wampserver رو پیشنهاد می کنم که کار کردن باهاش آسون تر و بهتر هست. اگه wamp رو نصب کردی خبرم کن تا بگم چیکار کنی تا mode rewriter کار کنه
غایب
  پاسخ
تشکر شده توسط :
#3
منم به شدت توصیه می کنم wampserver نصب کنی
همه جوره اش رو داریم ظاهرن
  پاسخ
تشکر شده توسط :
#4
من کلا از این ایزی پی اچ پی بدم میاد . خیلی مشکل داره
و خیلی وقته با xxamp کار میکنم اگر خواستید با این کار کنید بگید تا راهش رو بزارم
  پاسخ
تشکر شده توسط : aligilani1986
#5
من هم با Wamp استفاده میکنم ، اما نمیدونم چرا اون آیکن کنار ساعت که از برنامه قرار میگره وقتی میخواد اجرا بشه Apache رو Run نمیکنه و زرد میمونه و واسه همین مجبور شدم Easyphp استفاده کنم فعلاً

حالا شما کلا با هر برنامه ای کار میکنید طرز کارشو بگید که چجوری این کار انجام میشه !؟
---------------------------------------------------------------------------
خدایا ، مگر می شود تو باشی و ما تنها باشیم ؟
  پاسخ
تشکر شده توسط :
#6
XXAMP به یه سرور واقعی شبیه تره ، اما من هم از WAMP استفاده می کنم Smile
  پاسخ
تشکر شده توسط : zoghal
#7
(۱۳۸۸ فروردین ۱۸, ۰۴:۲۱ ب.ظ)abedi98 نوشته: من هم با Wamp استفاده میکنم ، اما نمیدونم چرا اون آیکن کنار ساعت که از برنامه قرار میگره وقتی میخواد اجرا بشه Apache رو Run نمیکنه و زرد میمونه و واسه همین مجبور شدم Easyphp استفاده کنم فعلاً

حالا شما کلا با هر برنامه ای کار میکنید طرز کارشو بگید که چجوری این کار انجام میشه !؟

شاید port 80 بستست بیشتر مشکل از IIS هست که باید استاپ بشه
  پاسخ
تشکر شده توسط :
#8
من هم با xampp موافقم ولی می تونی خارج از این بحث که کدوم یکی بهتره کدی رو که داخل فایل htaccess. قرار دادی اینجا بزاری تا اون رو هم بچه ها یه نگاه بهش بندازن .
  پاسخ
تشکر شده توسط : zoghal
#9
درسته که xampp خیلی حرفه ای و شباهت بیشتری به سرور داره اما wamp کاربران بیشتری رو به سمت خودش کشونده و تونسته رتبه بالایی در بین نرم افزار های هم موضوع خودش کسب کنه! [نتیجه 3 سال معرفی و آموزش نرم افزار ها]

من هم زمانی با این مشکل برخورد کرده بودم و دو دلیل بیشتر نداره!

1- شما اشتباهی یکسری از امکانات رو فعال کردید و یا در تنظیماتش دستکاری کردید که همیشه اینطوری میمونه جز زمانی که به اینترنت وصل هستید.
2- یا اینکه port 80 بسته هست.

برای رهایی از این مشکل هم باید یکبار کلا نرم افزار رو از control panel حذف کنید و از run بخش نرم افزار های نصب شده هم اطلاعات باقی مونده بر روی ویندوزتون رو هم پاک کنید تا بطور کامل حذف بشه! بعد شروه به نصب مجدد کنید و این دفعه فقط امکاناتی که در زیر برات شرح دادم رو فعال کنید:

1- از PHP settings تیک register global رو میزنی.
2- از PHP extensions تیک php_gd2 رو هم میزنین.
3- از Apache modules تیک rewrite_module رو هم میزنین.
4- php.ini رو از بخش PHP باز کنید و دنبال short_open_tag = off میگردین بعد مقدار اون رو به On تغییر میدید. (دقت کنید که 2 تا وجود داره و هردو تا باید به On تبدیل بشن!)

موفق باشید ...
غایب
  پاسخ
تشکر شده توسط : abedi98 alic
#10
من تا به با xxamp کار نکرده بودم ، دارم نسخه ویندوزش رو دانلود میکنم که حجم 80 MB داره ، دوستانی که با این برنامه کار کردن یک توضویحاتی راجبه قابلیت های اون و مقایسه با بقیه برنامه ها بگن و بعد اینکه فعال سازی Mod_rewrite رو در برنامه های زیر بنویسید که تاپیک کامل شه !

Wamp -- Xxamp -- Easyphp

_______
راستی اون مشکل با Wamp حل شد ‍! فقط اینکه الان مثلاً میخوام PHPMYADMIN رو باز کنم >>>>>
Welcome to phpMyAdmin

Error
MySQL said:

#2003 - Can't connect to MySQL server on 'localhost' (10061)

_______
---------------------------------------------------------------------------
خدایا ، مگر می شود تو باشی و ما تنها باشیم ؟
  پاسخ
تشکر شده توسط :


پرش به انجمن:


کاربران در حال بازدید این موضوع: 1 مهمان