• 0 رای - 0 میانگین
  • 1
  • 2
  • 3
  • 4
  • 5
باگ در ابزار برون بری و درون ریزی وردپرس
#1
فکر کنم اکسپورت و ایمپورت وردپرس مشکل داره.
هرچی بک اسلش بوده توی پستهای من از بین رفته! (طبیعتا بسیاری از کدهای درج شده در پستها هم خراب شدن).
نگاه میکنم توی نسخه های قدیمی تری که اکسپورت کرده بودم درسته، اما توی جدیدترها نیست.
فعلا دارم پستهام رو دونه دونه بررسی و اصلاح میکنم. کار درست کرد واسه ما!!
ضمنا بجای خود بک اسلش از & #92; استفاده میکنم تا اطلاع ثانوی.
  پاسخ
تشکر شده توسط :
#2
اون واسته تازه کارهاست .
دیتابیست رو انتقال بده چرا خودتو اذیت میکنی /
  پاسخ
تشکر شده توسط :
#3
البته فکر کنم از وقتی فایل xml ای رو که روی لوکال اکسپورت کرده بودم روی هاست ایمپورت کردم اینطوری شد.
احتمالا به تفاوت تنظیمات PHP هاست ربط داره. ولی بهرصورت نباید به این راحتی خراب بشه. باید پلاگین مخصوص این کار پیشبینی اینطور وضعیتها رو داشته باشه.

(۱۳۹۱ شهریور ۱۱, ۰۸:۴۲ ب.ظ)Reza نوشته: اون واسته تازه کارهاست .
دیتابیست رو انتقال بده چرا خودتو اذیت میکنی /
چه ربطی داره به تازه کار بودن؟
مشکل اینه باگ داره، وگرنه اگر درست باشه آدم چرا بیاد از راه سخت تر و طولانی تر اقدام کنه؟ یه حرفه ای هم نمیاد الکی وقت و انرژی خودش رو هدر بده.
  پاسخ
تشکر شده توسط :
#4
شایدم ورژن ها یکی نبودن .
  پاسخ
تشکر شده توسط :
#5
بله ممکنه، ولی اینم باگ همون سیستم میشه که این رو تشخیص نمیده و اطلاعات رو خراب میکنه.
گنجاندن اطلاعات نسخه و تنظیمات در فایل خروجی و تشخیص خودکار ناسازگاری ها درصورت لزوم، و سعی در تبدیل اونها یا اطلاع دادن به کاربر، وظیفهء چنین سیستمهایی هست.
بخصوص یک سیستمی که برای اکسپورت کردن و گرفتن نسخهء پشتیبان بکار میره طبیعی هست که ممکنه خروجی نسخه های قدیمی تر و جدیدتر اون با هم تبادل بشن و بنابراین باید حتما یا سازگاری بین نسخه ها حفظ بشه یا بصورت خودکار تبدیل صورت بگیره و خلاصه یه راه حل قابل قبولی داشته باشه برای اینطور موارد.

احتمالا این سیستم اکسپورت و ایمپورت وردپرس چیز نسبتا جدیدی باشه.
ضمنا جالبه که موقعی که برای اولین بار میخوای ایمپورت کنی تازه اون پلاگین لازم رو دانلود میکنه (ولی برای اکسپورتش مشکلی نداره).
نمیدونم چرا اینطوریه. خب بصورت پیشفرض روش میذاشتن مگه چی میشد؟!
  پاسخ
تشکر شده توسط :
#6
http://wordpress.org/support/topic/plugi...ackslashes

بعد از دو ماه هنوز این باگ رو فیکس نکردن؟ Huh
  پاسخ
تشکر شده توسط :


پرش به انجمن:


کاربران در حال بازدید این موضوع: 1 مهمان