• 1 رای - 5 میانگین
  • 1
  • 2
  • 3
  • 4
  • 5
اساتید گرامی در اندروید تجربه دارند؟
#1
سلام دوستان.
من یک builder اندروید نیاز دارم.

مشخصات عکس رو توو تصویر زیر گذاشتم.
من این دوتایی که خط کشیدم رو نیاز دارم.
کسی اگه داشت بده.ممنون
[عکس: iFfbF.png]
  پاسخ
تشکر شده توسط :
#2
Gradle خودش یه builder هه که همراه با پکیج Android Studio نصب میشه
https://gradle.org

Apache Maven هم یک builder خوب و قدرتمنده
https://maven.apache.org

Ant
http://ant.apache.org
وبلاگ: Yousha.Blog.ir


 کد کمتر => خطای کمتر => قابل فهمتر => خوانایی بالاتر => نگهداری بهتر

  پاسخ
تشکر شده توسط :
#3
خب دوست عزیز-من این فایل ها یی که توو تصویره رو میخوام.از کجا بگیرم؟؟لینک دانلود داری بدی خیلی نیاز دارم-دعات میکنم
  پاسخ
تشکر شده توسط :
#4
اون دو گزینه در تصویر راست(در SDK Manager) فایل نیستند، پکیج هستن...
Build-Tools: شامل ابزارهای پکیج بندی(APK)، ابزاری های Decompile، تمیزکردن سورس درحال کامپایل، render گیری و...
Platform-Tools: شامل ابزارهای کنسولی مدیریت سیستم عامل اندروید و device هستش. (مثل adb)
برای نصب مجددشون کافیه که تیکش رو بزنی و مجددا نصبشون کنی. یا به مسیر C:\Users\Alessandro\AppData\Local\Android\sdk بری و پاکشون کنی و مجدداً نصبش کنی.


اون تک فایل تصویر سمت چپ هم gradlew بصورت خودکار یکبار توسط buildler Gradle تولید میشه...که مخفف Gradle Wrapper هستش.

اگر از gradle قدیمی استفاده می کنی:
میتونی با اضافه کردن خطوط زیر در فایل build.gradle:
کد:
task wrapper(type: Wrapper)
{
   gradleVersion = '2.1' // version!!
}
و اجرای دستور gradle wrapper، اون فایل رو مجدداً تولید کنید.

اگر از gradle جدید 2.4.x به بعد استفاده می کنی:
با زدن دستور gradle wrapper --gradle-version 2.4 اون فایل رو تولید کنی.

اطلاعات بیشتر: https://docs.gradle.org/current/userguid...apper.html


پی نوشت: اگر خیلی سختته یا به gradle مسلط نیستی پیشنهاد می کنم از Eclipse استفاده کنی... همراه با پکیج ADT
وبلاگ: Yousha.Blog.ir


 کد کمتر => خطای کمتر => قابل فهمتر => خوانایی بالاتر => نگهداری بهتر

  پاسخ
تشکر شده توسط :
#5
من باید از همین ورژن استفاده کنم-چون نیازه تا view ایمپورت بشه.
ورژن های دیگه ندارند چنین چیزی رو.
چه چیزی دانلود کنم این فایل داخلش باشه؟؟؟؟
این واسم حیاتیه-خواهش میکنم یه راهی برای حل مشکل بگین.
از طریق خود برنامه نمیشه.با کریo و فیxشکن هم نشد.
سرور گوگل جواب نمیده
  پاسخ
تشکر شده توسط :
#6
بعضی از دولوپرهای ایرانی... Angel

نقل قول:من باید از همین ورژن استفاده کنم-چون نیازه تا view ایمپورت بشه.
کدوم ورژن؟ چه برنامه ای؟
از view منظورت Layout ها هستش؟


نقل قول:ورژن های دیگه ندارند چنین چیزی رو.
چه چیزی رو؟


نقل قول:از طریق خود برنامه نمیشه.با کریو و فیلترشکن هم نشد.
سرور گوگل جواب نمیده
چی از طریق خود برنامه نمیشه؟
برای تنظیم پرoکثی، [email protected]، هرچی، باید مشخصات رو در Internet Options بزنی! نه جای دیگه... این subsystem نت ویندوزه هست
وبلاگ: Yousha.Blog.ir


 کد کمتر => خطای کمتر => قابل فهمتر => خوانایی بالاتر => نگهداری بهتر

  پاسخ
تشکر شده توسط :
#7
چطوری؟؟؟میشه بهم یاد بدید؟؟؟

این صفحه دانلود منه که ارور میده

متن کامل ارور بهمرا صفحه ارور
Loading SDK information...

Installing Archives:
Preparing to install archives
Installing Android SDK Build-tools, revision 23.0.0 (Obsolete)
Unzipping Android SDK Build-tools, revision 23.0.0 (Obsolete) (2%)
Unzipping Android SDK Build-tools, revision 23.0.0 (Obsolete) (4%)
Unzipping Android SDK Build-tools, revision 23.0.0 (Obsolete) (20%)
Unzipping Android SDK Build-tools, revision 23.0.0 (Obsolete) (21%)
Unzipping Android SDK Build-tools, revision 23.0.0 (Obsolete) (23%)
Unzipping Android SDK Build-tools, revision 23.0.0 (Obsolete) (27%)
Unzipping Android SDK Build-tools, revision 23.0.0 (Obsolete) (49%)
Unzipping Android SDK Build-tools, revision 23.0.0 (Obsolete) (50%)
Unzipping Android SDK Build-tools, revision 23.0.0 (Obsolete) (51%)
Unzipping Android SDK Build-tools, revision 23.0.0 (Obsolete) (53%)
Unzipping Android SDK Build-tools, revision 23.0.0 (Obsolete) (76%)
Unzipping Android SDK Build-tools, revision 23.0.0 (Obsolete) (80%)
Unzipping Android SDK Build-tools, revision 23.0.0 (Obsolete) (87%)
Unzipping Android SDK Build-tools, revision 23.0.0 (Obsolete) (88%)
Unzipping Android SDK Build-tools, revision 23.0.0 (Obsolete) (89%)
Unzipping Android SDK Build-tools, revision 23.0.0 (Obsolete) (90%)
Unzipping Android SDK Build-tools, revision 23.0.0 (Obsolete) (91%)
Unzipping Android SDK Build-tools, revision 23.0.0 (Obsolete) (92%)
Unzipping Android SDK Build-tools, revision 23.0.0 (Obsolete) (93%)
Unzipping Android SDK Build-tools, revision 23.0.0 (Obsolete) (94%)
Unzipping Android SDK Build-tools, revision 23.0.0 (Obsolete) (95%)
Unzipping Android SDK Build-tools, revision 23.0.0 (Obsolete) (97%)
Unzipping Android SDK Build-tools, revision 23.0.0 (Obsolete) (98%)
Unzipping Android SDK Build-tools, revision 23.0.0 (Obsolete) (99%)
Installed Android SDK Build-tools, revision 23.0.0 (Obsolete)
Done. 1 package installed.

[عکس: Untitled_1_copy.jpg]
  پاسخ
تشکر شده توسط :
#8
(۱۳۹۵ مرداد ۲۱, ۰۲:۱۶ ب.ظ)samanfc20 نوشته: من باید از همین ورژن استفاده کنم-چون نیازه تا view ایمپورت بشه.
ورژن های دیگه ندارند چنین چیزی رو.
چه چیزی دانلود کنم این فایل داخلش باشه؟؟؟؟
این واسم حیاتیه-خواهش میکنم یه راهی برای حل مشکل بگین.
از طریق خود برنامه نمیشه.با کریo و فیxشکن هم نشد.
سرور گوگل جواب نمیده

سلام
با چه تر شکنی امتحان کردید. من فقط با ف*لتر شکن freate تونستم دانلود کنم.
قبلش هم حتما در sdk manger و از Tools>Options ، پری و پورت رو تنظیم کنید.
HTTP Prxy Server : 127.0.0.1
HTTP Pry Port: 8580

اینا تنظیمات فری گیت هست
  پاسخ
تشکر شده توسط :
#9
(۱۳۹۵ مرداد ۲۱, ۰۷:۳۳ ب.ظ)MH_MA نوشته:
(۱۳۹۵ مرداد ۲۱, ۰۲:۱۶ ب.ظ)samanfc20 نوشته: من باید از همین ورژن استفاده کنم-چون نیازه تا view ایمپورت بشه.
ورژن های دیگه ندارند چنین چیزی رو.
چه چیزی دانلود کنم این فایل داخلش باشه؟؟؟؟
این واسم حیاتیه-خواهش میکنم یه راهی برای حل مشکل بگین.
از طریق خود برنامه نمیشه.با کریo و فیxشکن هم نشد.
سرور گوگل جواب نمیده

سلام
با چه ف*لتر شکنی امتحان کردید. من فقط با ف*لتر شکن free**gate تونستم دانلود کنم.
قبلش هم حتما در sdk manger و از Tools>Options ، پر*کسی و پورت رو تنظیم کنید.
HTTP Proxy Server : 127.0.0.1
HTTP Proxy Port: 8580

اینا تنظیمات فری گیت هست
ممنون دوست من-الان توی لود sdk از sdkmaneger مشکلی ندارم و بدون ارور گوگل لود میشه.
اما در تصویر فوق تغییری توی نصب 23.0.0rc2 تغییری بوجود نیومد و مجدد همون ارور ها با همون درصد های فوق ظاهر شد
  پاسخ
تشکر شده توسط :
#10
(۱۳۹۵ مرداد ۲۲, ۱۲:۲۸ ب.ظ)samanfc20 نوشته: ممنون دوست من-الان توی لود sdk از sdkmaneger مشکلی ندارم و بدون ارور گوگل لود میشه.
اما در تصویر فوق تغییری توی نصب 23.0.0rc2 تغییری بوجود نیومد و مجدد همون ارور ها با همون درصد های فوق ظاهر شد

این تصویر پست اول که گذاشتید از sdk manager خودتون هست ؟ اگه آره که شما اصلا این بیلدر رو نصب شده دارید و دیگه احتیاجی به دانلود نیست. status بیلدر 23 رو installed زده !!!!

این صفحه ارور رو اصلا cancel کنید. شما یکبار دقیق پروژه تون رو توضیح بدید اونوقت شاید دوستان بتونن کمکتون کنند. یه تصویر هم از صفحه build.gradle(Module:app)
بذارید.

مشکلتون رو دقیق شرح بدید !
  پاسخ
تشکر شده توسط :


پرش به انجمن:


کاربران در حال بازدید این موضوع: 1 مهمان